Author Topic: Zabbix dependcies unmet  (Read 45 times)

Offline William654

  • Newbie
  • *
  • Posts: 1
    • View Profile
Zabbix dependcies unmet
« on: June 11, 2019, 05:13:01 AM »
I want to upgrade a Zabbix 2.2.7 to a 3.4 but there is a problem when I want to install zabbix-server:

Code: [Select]
The following packages have unmet dependencies:
 zabbix-server-mysql :
Depends: libmariadbclient18 (>= 5.5.36) but it is not installable

Depends: libsnmp30 (>= 5.7.3+dfsg-1.7~dfsg) but 5.7.2.1+dfsg-1 is to be installed

Depends: libssl1.1 (>= 1.1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

libbssl1.1 and libmariadbclients are not avaialable, however I updated my repositories with apt-get update and apt-get upgrade.

And I don't know for libsnmp how to remove it and then install the new one.

Regards

Offline Tonyaphisak

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Zabbix dependcies unmet
« Reply #1 on: June 12, 2019, 09:34:32 AM »
It's a great story. I have discovered a website that can provide useful information for me.